KavenWong
Topic Author
Posts: 6
Joined: 08 Oct 2019, 08:55

Data delay in NodeRed dashboard (RevPi Connect is okay, Core S is not)

27 Sep 2022, 17:54

Hello,
we are encountering a funny behavior. We are running the same software and node-red version on a RevPi Connect (Old version, bought ~1-2 years ago) and a Core S (8 GB), bought recently. The OS is likely to be different (Both devices are at a fair, so I can't check at the moment). Our software reads data from a tension sensor and sends it via WebSockets to NodeRED, which then shows it to a linear plot (data of last 1 minute) (NodeRed dashboard plugin).

If we apply tension on the sensor, we notice that the old device (RevPi Connect) updates the plot values immediately, while the newer device (Core S) lags for a few seconds (up to 30 s) before showing the change. We checked using a debug node and the data fed to the plots in the Core S device (the one showing the delay) are properly synchronized, so the problem is happening on the plotting side.

We are not doing anything crazy, sampling rates of 1 Hz and only 1 minute of data, so I don't think we are taxing the cpu/memory enough to be a problem. Even if it was so, the RevPi Connect is supposed to have inferior specs when compared to the Core S. Therefore, we are puzzled with what we are experiencing. Does anyone can give me a clue of what could be happening here?

Thank you in advance.
 
User avatar
nicolaiB
KUNBUS
Posts: 714
Joined: 21 Jun 2018, 10:33
Answers: 1
Location: Berlin
Contact:

Re: Data delay in NodeRed dashboard (RevPi Connect is okay, Core S is not)

27 Sep 2022, 18:06

Hi,

without any version numbers of NodeRed, RevPi Server, RevPi Nodes and the image itself, it is impossible to suggest something. So please share more information about your setup. My guess would be something with the 3rd party revpi nodes.

Nicolai
 
KavenWong
Topic Author
Posts: 6
Joined: 08 Oct 2019, 08:55

Re: Data delay in NodeRed dashboard (RevPi Connect is okay, Core S is not)

27 Sep 2022, 19:40

Unfortunately, I don't have access to the device at the moment. When I do, I will get the information you asked and come back to the forum. Thank you for your help.
 
jgerlach-erminas
Official 3rd Party Support Erminas
Posts: 33
Joined: 22 Jan 2020, 14:31

Re: Data delay in NodeRed dashboard (RevPi Connect is okay, Core S is not)

29 Sep 2022, 15:51

Hello,

thanks for reporting this. We are tracking the potential RevPi Nodes issue here. Feel free to post additional information here, on the linked issue tracker or contact me directly.

Greetings,
Jonas

Who is online

Users browsing this forum: No registered users and 0 guests