a.spachos
Topic Author
Posts: 1
Joined: 12 Jul 2021, 14:00

Problem installing Node-RED

12 Jul 2021, 14:15

Hi,
i have a problem installing Node-RED in RevPi Core (REVPI CORE S/N: 52303)

RevPi Version: 2017-09-22-revpi-jessie.img

When running the script from https://nodered.org/docs/getting-started/raspberrypi first it says
node: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by node)
node: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by node)
node: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by node)
node: /usr/lib/arm-linux-gnueabihf/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by node)

and then at step Install Node.js for Armv6 it exits with the following message:
Bad install: Node.js missing Npm missing - Exit
 
User avatar
dirk
KUNBUS
Posts: 1667
Joined: 15 Dec 2016, 13:19
Answers: 1

Re: Problem installing Node-RED

26 Jul 2021, 09:47

Hi a.spachos, please upgrade your system to Buster.
https://revolution.kunbus.de/shop/en/buster

Who is online

Users browsing this forum: No registered users and 0 guests